Problem mit Flats, negative Vignette?

  • Hallo Allerseits,


    ich verzweifle gerade an meinen Flats....
    Aufnahmeoptik ist ein TS Apo 80/480 mit einer Zwo ASI294MM-Pro. Aufnahmesoftware ist KStars/Ekos auf Astroberry, Bildverarbeitung PixInsight 1.8.8-12 auf Linux.

    Die Bildgewinnung läuft ganz normal, nur beim Stacken kommt es zu diesem komischen Effekt. Ohne Flats (und FlatDarks) schaut das Ergebnis wie erwartet aus - die Mitte heller zum Bildrand hin radial dunkler. Die klassische Vignette eben.

    Nehme ich nun die Flats dazu, dreht sich das um =O


    Irgendwie wirken tut das Flat allerdings, die Dustmotes sind weg. Aber wie kommt es zu dieser Überkompensation zum Rand hin?
    Ich habe schon unter Windows (so schwer mir das fiel) mit DSS gestackt und mit Pix (Win) geschaut - gleiches Ergebnis, ich habe unter NINA den Flat Assistant genutzt und neu gestackt, wieder nix.

    Ich habe mit und ohne Taukappe Flats gemacht, dito.

    Die Flats sehen eigentlich soweit gut aus. Ich habe sie mit unterschiedlichen Ziel-ADUs gemacht, zwischen 16k und 8k. Das Ergebnis war an sich immer gleich. Das Flat hatte in der Mitte ca 150 ADU mehr als der Rand, was aber auch zum Himmelshintergrund in den Lights passen würde. Das einzige was ich wohl noch nicht probiert habe ist mit einem invertierten Flat zu Stacken.


    Irgendwie bin ich mit meinem Latein am Ende. An welcher Stelle mache ich den Fehler, was kann ich noch probieren?
    Ideas very welcome ;)


    Viele Grüße und CS

    Andreas

  • Hallo Andreas,


    welche Belichtungszeit haben deine Flats und deine Flatdarks?

    LG Frank

  • Hi Frank,


    danke für deine Hilfe!

    Je nach ADU so zwischen 0,5 und 1s.

    Gemacht habe ich sie mit einem Geoptik Flat Generator, also EL-Folie.

    Ich hab davon je 70, dazu 30 Darks und bei meinem letzten Test 100 Lights. Immer paarweise passend zu den Belichtungszeiten.


    Das hab ich dann ans WBPP verfüttert. Da habe ich die Standart- Einstellungen gelassen. Nur bei Subframe Weighting habe ich Weighting Formula und Galaxy (je nach Objekt) gewählt. Image Registration und Image Integration sind auch aktiviert.


    CS

    Andreas

  • Hallo Andreas

    kann das sein, dass die EL-Folie flackert? Kann bei kurzen Bel-Zeiten schon Probleme machen.

    Schau deine Flats einzeln durch da siehst du ev. Unterschiede.

    LG Franz

  • Hallo Andreas,


    ich fotografiere mit einer Asi1600Mono und einer AltairHC294MC. Und letztere hatte ich diese Woche auch im Einsatz und das gleiche Ergebnis wie du, aber nur wenn ich zur Bildbearbeitung keine Darks hinzu nehme.

    Ich kam nur zufällig zu diesem Effekt, da ich meine Darks am C11 bei Tag gemacht habe und mir irgendwo Streulicht eingefangen habe. Also lies ich die Darks weg und der von Dir beschrieben Effekt taucht auf. Und das egal ob die Flats mit einem Darkflat kalibriert sind oder nicht.

    Es scheint (bei mir) mit den fehlenden Darks zusammenzuhängen. Aber ich habe keine Ahnung, ob das nun logisch ist oder nicht... :huh:



    Links mit mißratenenen MasterDark + MasterFlat und rechts nur mit Flats (Masterflat = Flat - Darkflat)


    VG und CS

    Thomas


    P.S. meine Flats sind mit der T-Shirt Methode entstanden. Also kein Geflackere möglich...

    Edited once, last by tgd16: Erklärung hinzu ().

  • Hi Thomas


    Wenn du keine Darks machst, musst du Bias von deinen Lights abziehen. Dann sollten die Flats eigentlivh wieder passen.


    CS, Seraphin

  • Hallo Seraphin und Andreas


    ja, korrekt. Nur hat dieser Chip offensichtlich Probleme mit den Biasen. Die allgemeine Empfehlung aus dem Netz lautet Flats mindestens 3sec zu belichten und mit Darkflats zu kalibrieren. Meine Flats waren nur 0,014 Sekunden, also viel zu kurz. Evtl. bei Dir, Andreas die gleiche Problematik?


    VG und CS,

    Thomas

  • Hi Allerseits!


    Vielen Dank für die Tipps! Ich habe meine Flats mal alle 'durchgeblinkt' - kein Flackern, alle quasi identisch.

    Ich hatte meine Lights 120s belichtet und entsprechend auch 120s Darks dazu gepackt. Flats dito mit 0,56s in dem Fall, es waren also immer Paare.

    Thomas' Hinweis ist allerdings spannend. Ich werde nacher mal eine Serie Flats mit längerer Belichtung machen und das dann noch mal stacken.

    Bin gespannt was dabei rauskommt, ich werde berichten :)


    Bis später

    Andreas

  • Hi!


    Ich hab dann mal 3s Flats und passende FlatDarks gemacht; Leider keine Änderung der Lage.

    Ebenfalls habe ich dann testweise mal die FlatDarks und auch die Darks weggelassen ....

    Es bleibt dabei, sowie ich Flats in Spiel bringe habe ich diesen Effekt.

    Und wie gesagt, ich kann es ja auch mit DSS reproduzieren.

    Bei den Aufnahmen mit meiner 183MM-Pro hat alles einwandfrei funktioniert. die 294MC-Pro hier spinnt

    (Sorry, ich hab mich im Einganspost mit dem Typ vertippt, es ist eine ASI294MC-Pro)

    Ich bin echt ratlos ...


    CS

    Andreas

  • da gibt es sicher eine Lösung, ich denke der Sensor hat hier seine Eigenarten. Meine 1600 reagiert hier auch total gutmütig, vor solchen Themen stand ich dort noch nicht. Eine Möglichkeit wäre auch noch im ZWO Forum zu fragen.


    Wie hast Du denn die Flats und Darkflats verarbeitet? In WBPP komme ich mit Darkflats nicht zurecht. Ich erstelle erst ein Masterdarkflat (ImageIntegration), dann kalibriere ich die Flats mit dem MasterDF, erstelle dann ein Masterflat und gehe anschließend mit dem Masterdark, Masterflat und den Lights ins WBPP.


    Irgendwo las ich vor kurzem auch, dass Flats eher im ADU Bereich der Lights erstellt werden sollten. Das ist allerdings gegen die allgemeine Regel, dass das Histogramm der Lights sich irgendwo in der Mitte befinden sollte.


    VG und CS,

    Thomas

  • So siehts derzeit aus:



    Oben links: Stack mit Darks, Flats, FlatDarks

    Oben rechts: Stack mit Darks, Flats

    Unten links: Stack mit Flats

    Unten Rechts: Stack mit Darks


    Sowie Flats im Spiel sind habe ich dieses Verhalten, bei der 294MC-Pro zumindestens.

  • Da blüht mir wahrscheinlich das Gleiche...

    Und so kommt mir nur noch die Idee des "künstlichen Flats". Tommy Nawratil hat das mal in einer Abhandlung beschrieben: Flatfielding durch Erstellung eines künstlichen Flats. Damit bekommst Du dann auch die Donuts und Gradienten raus.

    Kennst Du das? Das wäre mein nächster Versuch. Wenn du deine bevorzugte Suchmaschine bemühst findest du eine Anleitung als PDF.

    Wenn du es nicht findest schick mir eine PN.


    VG und CS,

    Thomas

  • Ich stelle mal Vermutungen hier an, da ich ganz stark den Sensor im Verdacht habe. Der hat mich, da es meine erste richtige Astrocam war, ziemlich durcheinander gebracht. Eigentlich hat dieser deutlich feinere physikalische Pixel als man annimmt (2,3my anstelle 4,6). In der MC Version werden diese jeweils zu vieren in einem Binning zusammengefasst. Dass dann in der Folge komische Auswirkungen zu Tage treten wundert mich nicht.


    Siehe auch: https://astronomy-imaging-camera.com/product/asi294mm-pro

  • Hi Thomas,


    das WBPP ist da ziemlich einfach. Darks und DarkFlats kommen in den Bereich Darks, Flats zu den Flats und die Lights zu den Lights.

    Im Subframe Weighting habe ich auf Weighting Formula umgestellt und suche mir dann je nach Objekt aus was es ist.


    Verarbeitung der Lights


    Calibration im WBPP


    Darks und FlatDarks


    Das WBPP sucht sich dann die passenden zusammen, hat bei meiner 183MM ja auch funktioniert, allerbest sogar und quer durch alle Filter.


    Ich habe dasselbe Verhalten ja auch bei DSS und auch wenn ich die Bilder mit NINA mache. An der Software kann es ja fast nicht mehr liegen.


    Viele Grüße und CS

    Andreas

  • Ich stelle mal Vermutungen hier an, da ich ganz stark den Sensor im Verdacht habe. Der hat mich, da es meine erste richtige Astrocam war, ziemlich durcheinander gebracht. Eigentlich hat dieser deutlich feinere physikalische Pixel als man annimmt (2,3my anstelle 4,6). In der MC Version werden diese jeweils zu vieren in einem Binning zusammengefasst. Dass dann in der Folge komische Auswirkungen zu Tage treten wundert mich nicht.


    Siehe auch: https://astronomy-imaging-camera.com/product/asi294mm-pro

    Hmm, die Bayer-Maske gibt es ja nun schon länger, ist halt das RGGB Zeugs.
    Wie sieht das eigentlich mit den EL-Folien aus, das sind sicherlich keine Kontinuumstrahler. Kann das diese Effekte hervorrufen?

    Dann sollte ich vielleicht mal ein Flat am Himmel probieren ....

  • Hallo


    Wenn du für die Lights keine Darks hast dann wenigstens Bias abziehen,

    Wüsste nicht wo das Problem dabei ist, die gehen zur Not auch mit 1s


    Gruß Frank

  • Hallo Andreas,


    meine Flats entstanden am Hmmel mit T-Shirt... und dennoch diese "negative Vignette"


    Die Bayer-Maske ist ja ok, aber - so mein Verständnis- bezieht sich ein Farbfeld auf einen physikalischen Pixel und nicht auf vier. Da muss softwaretechnisch mehr Aufwand betrieben werden. An dem Punkt bin ich jedoch kein Experte.

    Bei mir laufen gerade weitere Testaufnahmen am C11 und der Altair 294C (ungekühlt). Ich probiere mich an der richtigen Kollimation des C11, dem richtigen Abstand des Reducers im Blendrohr (und nicht nur zum Chip). Die Darks sind heute wirklich dark (dank Telegizmos) und die Flats versuche ich morgen mal mit ganz geringem ADU.


    VG und CS

    Thomas

  • Hallo Frank,


    fotografierst Du auch mit einem IMX294er Chip? Dieser verhält sich wohl bei vielen Kollegen wie eine Diva. Und viele suchen nach einer Anleitung zum Zähmen dieses Teils.

    Sensoren wie in der 1600er verhalten sich wirklich komplett anders. Leider ist das auch meine praktische Erfahrung.


    VG und CS

    Thomas

  • Hallo


    Rein der mathematischen Formel für die Bildkorrektur kann die Flat division nur funktionieren wenn von den Beteiligten das Bias abgezogen wird.

    Es gibt natürlich Bildbearbeitung software welche die Flats. Automatisch anpasst, Fitswork wollte das gekonnt haben.

    Aber wenn es Probleme mit Biasabzug gibt kann man dank geregelter Kühlung ja auch Darks machen, die wären jetzt schon fertig.


    Wenn alle nicht hilft in einem Photobearbeitungsprogramm mit Ebenentechnik, kann man das über die Deckkraft nachkorrigieren


    Gruß Frank

  • Hallo


    Bei Bayermaskenflats besteht schon das Problem das nicht alle Farben richtig belichtet sind, müsste man das Flat man zur Kontrolle debayern um die Belicntungskurven zu sehen, die dürfen auf keinen Fall unter oder Überbelichtet sein das die Kurven beschnitten sind.


    Gruß Frank

  • Schaut mal ob euch das hier weiter hilft:


    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Diese Überkorrektur hat m.E. immer etwas mit den Bias zu tun.

    CS Frank

  • Moin!


    Ich habe in der Zwischenzeit so ziemlich alle Varianten durchprobiert und bin leider noch auf keinen grünen Zweig gekommen.

    Ich hab die FlatDarks als BIAS genutzt, die Werte im Flat angehoben, mich auch am künstlichen Flat versucht .....

    Was mich auch irritiert ist, dass die Flats der 294 etwas anders aussehen als die mit der 183MM.


    Ich hab so den Eindruck, ich mache da etwas elementar falsch, vielleicht ist es auch die Geschichte mit der EL-Folie.
    Daher werde ich bei nächster Gelegenheit 'T-Shirt-Flats' machen und es mal damit versuchen.
    Das Gute ist, dass ich die Lage der Kamera habe und die OAZ-Position jederzeit über den Fokusmotor und damit die Flats reproduzieren kann. So gesehen läuft (ausser vielleicht wanderndem Staub) nichts weg und ich habe alle Zeit der Welt zum experimentieren ;)

    Ich bleibe da am Ball, äääh Chip und berichte wenn es was Neues gibt. Hab dadurch viel gelernt.

    Auf alle Fälle ein riesengroßes Danke für eure Tipps und Ideen!


    Viele Grüße und CS

    Andreas

  • Hallo Thomas,


    lass uns doch erst mal einen Rohdatensatz (1 Light, 1 Dark, 1 Flat, 1 Flatdark und der vollständigkeit halber 1 BIAS) zu Fuss analysieren.

    Wenns da funktioniert, scheidet die Kamera als Ursache aus, und man erspart sich unnötige Spekulationen.

    Ich bin mit Linux,Ekos usw leider nicht vertraut, würde mir die Bilder aber gerne mal anschauen, bevor sie im großen Fleischwolf von WBPP zur Stackwurst verarbeitet werden.

    Vielleicht kannst Du die Rohdaten irgendwo hochladen, wo auch ich als bedauernswerter Wanderer im Windows Universum zugreifen kann.

    Das Rumprobieren mit "ohne flat, ohne darks" oder nur "ohne darks mit Bias" usw. ist so sinnvoll wie das Rumstochern mit einem Schraubenzieher im kaputten Radio.

    Kann man machen, funktioniert aber nur sehr selten...


    Ist die Vignette dagegen schon zu sehen, liegt es entweder an der Kamera oder der Flaterstellung.


    Viele Grüße

    Norbert

  • Hallo,


    ich hatte auch am Anfang Problem mit den Flats und den komischen Farbverläufen...


    Ich benutze zur Zeit nur Flats und Lights (also keine Darks und Bias).

    Ich stacke mit Siril und hier ist es dann sehr wichtig, dass beim Erstellen des Master Flats ein Bias mit abgezogen werden muss, sonst geht die Kalibration nicht.


    Hierzu verwende ich einen Bias-Faktor mit "=2048". Das ist dann ein synthetischer Bias Wert für meine Canon600d. Den habe ich vorher laut einer Anleitung zum synthetischen Bias von Siril ermittelt.


    Das klappt dann ganz gut!


    Gruß und CS

    Matthias

    8" -f6 Newton, Selbstschliff

    im Gitterohrtubus "deep blue" platziert

    mit Selbstbau-Reibradantrieb angetrieben

    und wohl temperiert und allzeit startklar in der Gartensternwarte montiert

    Canon600D, ASI178 und ASI120mini zum Guiden, GPU Koma Korrektor

  • Hallo Norbert,


    ich war bisher eher visuell unterwegs und noch nicht so lange bei der Fotografie. Auch bei PixInsight bin ich eher in der Kennenlernphase
    und in weiten Teilen auf die Stackwurstautomatismen angewiesen. Ich bin erst über Franks (frasax) hervorragende Tutorials zu gekommen
    PixInsight überhaupt zu nutzen.
    Mit der Asi182MM-Pro komme ich soweit recht gut zurecht, aber die OSC treibt mich in den Wahnsinn.
    Bildverarbeitung ist noch nicht so meins. So gesehen, ja ich bin noch beim Stochern mit dem Schraubenzieher, würde aber gern dazulernen ;)

    Wenn du mir sagen könntest wonach ich suchen muss würde mir das vielleicht schon helfen. Wenn du mir da helfen könntest, wäre das super.
    Einen Link für den Download schicke ich dir per PN


    CS

    Andreas


    PS das mit Win vs Pinguin darfst du nicht so ernst nehmen, da hab ich den ;) vergessen

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!