Hotpixel - mal sichtbar, mal nicht

  • Hallo zusammen,


    mir ist in den letzen Nächten ein Phänomen aufgefallen, über das ich schon seit einiger Zeit grübel.


    Ich habe zwei Aufnahmen des Kometen C/2017 T2 (PANSTARRS) gemacht, beide mit meiner EOS 250D.
    Das Bild mit M81/82 entstand per Sigma 18-300 bei 300mm und F5.6, die Nahaufnahme per Skywatcher 254/1200er Newton.


    Beide Bilder bestehen aus Einzelaufnahmen á 120sek, die ISO liegt bei 3200 (Objektiv) und 1600 (Newton).


    Auf den Bildern des Newton ist mir schon bei einigen Sessions aufgefallen, dass sämtliche Hotpixel nach dem Stack als dunkle Linie dargestellt werden - die geht offenbar darauf zurück, dass das Bildfeld trotz Guiding leicht verrutscht ist.


    Allerdings habe ich genau diese Striche nicht, wenn ich ein Objekt mit meinem Objektiv, Maksutov oder SC fotografiere. Ein Freund berichtete ebenfalls von diesem Phänomen - ebenfalls nur am Newton.



    https://up.picr.de/38655733bw.jpg



    https://up.picr.de/38655703ru.jpg



    https://up.picr.de/38655693yz.jpg



    Es wirkt so, als könne DSS bei diesen Bildern die Darks nicht richtig verrechnen, was mich wundert.


    EDIT: Ich habe festgestellt, dass ich auf Bildern mit ISO1600 oder weniger ebendiese Hotpixel habe, während bei ISO3200 keine Hotpixel mehr zu finden sind. Das finde ich ungewöhnlich, da die Anzahl der Hotpixel ja eigentlich mit der Empfindlichkeit des Sensors steigen sollte!?


    Hat das noch jemand und weiß vielleicht, warum? Und wie kann ich dem Problem entgegenwirken?


    Viele Grüße und CS
    Tobi

  • Hallo Tobi,
    das sieht für mich einfach nach überkorrigierten Hotpixeln aus. Das passiert, wenn die Temperatur zu hoch war bei den Darks, oder wenn die Kamera schon eingestellt ist auf "Rauschreduzierung" Möglicherweise ab einer bestimmten ISO Höhe, usw. Mit den Teleskopen oder DSS hat das nichts zu tun.
    Nach Guiding sieht das irgendwie auch nicht aus.
    Viele Grüße,
    ralf

  • Hallo Tobi , Hallo Ralf,
    Was mich immer wundert, ist die Länge der Spuren. Man macht einzelne Bilder, wo der Stern relativ rund ist und am Ende entstehen solche Spuren, von enormer Länge. Wann findet da der Versatz statt, in den zwischenzeiten zwischen den Bildern? Dieser wird doch relativ kurz sein , im Verhältnis zum light. Müsste es sich nicht auch an der sternenabbildung bemerkbar machen? Ich meine wir haben hier ja 120 Sekunden belichtungen.
    Viele Grüsse und schöne Pfingsten

  • Hallo Ihr drei,


    Die Rauschred der Kamera dürfte an sein, vielleicht schalte ich die nächstes Mal einfach aus. An der Temperatur liegt es nicht, denn im Winter hab ich das Phänomen eben genauso gehabt, in der gleichen Intensität. Was mich so wundert ist, dass der Effekt nur bei ISO-Werten unter ISO3200 auftritt. Danach ist nichts mehr zu sehen. Selbst bei ISO25600 nicht, die ich einstelle, wenn ich mich orientieren will.


    Ralf, warum sieht das für Dich nicht nach Guiding aus? Ich habe geguidet, allerdings nahe Polaris. Ich vermute, deswegen ist mir das Bild mit der Zeit leicht verrutscht.


    Alex' Verwunderung teile ich ebenfalls. Wahrscheinlich sind es nur so kleine Schritte, dass das nicht auffällt. Denn gedithert habe ich nicht. Diese "walking noise" kommt wenn dann nur von der reinen Verschiebung des Bildfelds.


    Ich versuche weiter und berichte, wenn ich noch was rausfinde.


    Viele Grüße und ebenfalls schöne Pfingsten
    Tobi

  • Ich habe gestern Abend M13 gemacht, ISO1600 und 180s. Diesmal haben sich die Sterne keinen Pixel bewegt über die Zeit. Die Pixelfehler sind auf den Rohbildern sichtbar, wurden aber beim Stacking perfekt rausgerechnet. Vielleicht hat DSS ein Problem damit, wenn sich das Bildfeld über die Zeit bewegt? Wobei die Pixelfehler ja Sensorgebunden und damit komplett statisch sind. Komische Sache.


    Dithering wollte ich zunächst noch nicht machen - dafür bin ich noch zu neu in der Astrofotografie. Ich will lieber erstmal geguidet einige Erfahrungen sammeln. Vielleicht beschäftige ich mich damit nächsten Winter mal :)

  • <blockquote id="quote"><font size="1" face="Verdana, Arial, Helvetica" id="quote">Zitat:<hr height="1" noshade id="quote">Vielleicht hat DSS ein Problem damit, wenn sich das Bildfeld über die Zeit bewegt? Wobei die Pixelfehler ja Sensorgebunden und damit komplett statisch sind. Komische Sache.<hr height="1" noshade id="quote"></blockquote id="quote"></font id="quote">Richtig, dann ist der auf den Chip bezogene statische Pixelfehler an verschiedenen Positionen des verschobenen Bildausschnitts zu finden.

  • Hallo Tobi,
    die "Rauschreduzierung bei Langzeitbelichtung" macht schon so Einiges. Je nach Einstellung auch interne Darks (und vieles andere, was wir nicht wissen) Wenn du jetzt noch mal Darks machst, dann ist das doppelt und das Hot Pixel wird zum Schwarzpixel. Was genau und ab wann in der Cam was passiert ist unbekannt. Chiptemperatur, Belichtungsdauer und ISO Einstellung sind auf jeden Fall Parameter die dabei berücksichtigt werden. Die Grenze zwischen 1600 und 3200 spielt da sicher eine Rolle. Ich vermute auch mal, dass 1600 noch im normalen Menü einstellbar ist und 3200 in "ISO-Erweiterungen".
    Diese "Black-Pixel" wandern auf deinem Bild und zwar gerade so, wie bei mir, der nicht guidet. Beim Guiding hätte ich erwartet, dass die Achsen den Stern an Ort und Stelle "fest halten". Dithern versetzt das Bild zwar immer um einige Pixel, aber so ein Strich dürfte dabei nicht heraus kommen.
    Viele Grüße,
    ralf

  • Hallo ihr Drei,


    Toni, ich guide per Laptop (Win8) und PHD2. Bin aber aktuell dabei, für mobile Zwecke aufn RaspberryPi umzusatteln, entsprechend schwierig wird es, ein passendes Programm fürs Dithern zu bekommen.


    Stefan, ja das macht Sinn. Allerdings müssten diese Fehler dann ja auch bei perfektem Guiding zu finden sein (also auf dem Endergebnis), nur halt auf diesen Pixel begrenzt. Das ist aber nicht der Fall. Vielleicht schafft es DSS da ja dann, die Fehler rauszurechnen, im Falle der Verschiebung aber nicht.


    Ralf, komischerweise bekomme ich dasselbe Ergebnis, egal ob ich mit oder ohne Darks stacke. Vielleicht geht das auch auf die automatische Hotpixel-Erkennung in DSS zurück?
    Alle ISO-Werte bis zum Maximum von 25600 sind im normalen Menü wählbar, eine "ISO-Erweiterung" hat die 250D nicht.
    Warum genau das Guiding verrutscht, weiß ich leider selber nicht. PHD2 macht keine Fehler, es ist kein Bild verzogen ö.Ä. Leitrohr und Hauptrohr sitzen ebenfalls bombenfest aufeinander, Verrutschen ausgeschlossen, wenn dann würd ich das auch eher Ruckartig vermuten und nicht über die Zeit verteilt.


    Viele Grüße
    Tobi

  • Hallo Tobi,
    Da bin ich ganz bei dir. 120 Sekunden Belichtung und Runde Sterne, lassen auf ein guiding vermuten, dass doch einigermaßen funktioniert. Wie gesagt sind 120 Sekunden auch nicht kurz, so dass eigentlich die lights auch betroffen sein müssten, in dem Maß, wie auch deine hotpixel wandern, sofern es welche sind. Wenn du schreibst, dass der Fehler auch ohne Dark entsteht, wird ja auch nix, bis zum völligen schwarz, subtrahiert. Was man machen könnte, sich mal Bild eins und das letzte genau anschauen. Gibt's da einen versatz, bzw. sind die deckungsgleich? Der Versatz müsste , sollten es die beschriebenen Fehler sein, sich auch entsprechend diesen bewegen. Hast du keinen versatz, dann sind es auch keine "wandernden" hotpixel. Wenn diese aber nicht wandern, hättest du schwarze Punkte. Ich tippe hier, genau wie du ,auf was ruckartiges....also meine Meinung. Übertrieben gesagt, warum sollte ein Bild mit zum Beispiel 5 min. Belichtung und Runden Sternen über das ganze Bild, im Bild 2 plötzlich " total" verdreht sein? ...oder denk ich da falsch. Könnte natürlich sein.
    Viele Grüsse

  • Hallo Tobi,


    ich teile die Einschätzung von Ralf, dass überkorrigierte Hotpixel die Ursache sind und Rauschreduzierung durch die Kamera strikt vermieden werden sollte. DSS ist sicher nicht die Ursache des Problems: Bei Abzug des Darks vom Rohbild geht die spätere Position nicht ein.
    Die Empfindlichkeit der Kamera ist bei ISO 3200 übrigens nicht wirklich höher als bei 1600, da wird nur der Pegel hochgedreht.
    Einen Unterschied bei verschiedenen Teleskopen könnte das freie Volumen zwischen Sensor und Optik bewirken, weil es die Erwärmung bzw. Kühlung des Sensors beeinflusst.


    Dithern würde das Problem sicher mildern. Ich persönlich finde es aber sinnvoller (und befriedigender) die Ursachen zu ergründen und abzustellen, statt mit der Schwamm-drüber Methode zu arbeiten.


    --&gt; Alex: Die Drift trotz Guiden entsteht dann, wenn das Teleskop nicht perfekt ausgerichtet ist und der Leitstern relativ weit abseits liegt. Dabei entsteht i.d.R. eine Bildrotation, aber nicht um die Aufnahme, sondern um den Leitstern. Die Drift während einer Aufnahme ist dann ca. die Gesamtdrift geteilt durch die Zahl der Aufnahmen.

  • Hallo Erwin,
    Sicherlich stimmt das, was du schreibst von bildfeldrotation und schlechter einnordung. Es ist aber für mich nicht ganz einfach zu verstehen, wenn man zum Beispiel 30 Aufnahmen a 2 min. tätigt und dafür 1 h und 2 min. braucht. Eine Stunde wird belichtet und die 2 min. verteilen sich auf die Pausen. Sieht man sich die Sterne in der nähe der hotpixel an, die ja in der gesamten Serie in der nähe dieser liegen müssten, sind die rund.(zumindest wird nicht beschriebenen, dass es nicht so ist) Der verschnitt , nach dem stapeln dürfte doch nicht dieses Ausmaß haben, dass solche Spuren entstehen.
    Wie gesagt , irgendwie geht das nicht in meinen Kopf. Naja , es wird schon so sein, wie du schreibst und die Sterne sind demnach nicht rund. Ich hätte aber erwartet, dass es in den einzelbildern von 2 min. Belichtung , erkennbar wäre. Nun steht leider nicht da, wie viele Bilder die Serie hat. Ein ehemaliger astrokollege hatte mal ähnliche Probleme, bei belichtungen von länger a 5 min.
    Ps. Hatte mir nochmal den ersten Beitrag durchgelesen. Da steht, tritt nur beim Newton auf, nicht beim sc und auch ohne darks. Wenn aber keine darks, dann doch auch keine überkorrigoerung durch Abzug. Aber das von mir trifft nicht den Kern der ursprünglichen Frage, dass steht hinter meinem ps.Sorry.
    Viele Grüsse

  • Hallo Tobi,


    die dunklen Striche sind der Weg der chipbezogen ortsfesten Hotpixel während der gesamten Aufnahmezeit der geguideten Aufnahme.
    Hättest du nicht geguidet, wären die Hotpixel schwarze (bildbezogen ortsfeste) Punkte und die Sterne hätten Strichspuren mit genau derselben Form deiner schwarzen Linien.


    Dein im Vergleich zum Maksutov oder MC deutlich lichtstärkerer Newton lässt den Hintergrund heller erscheinen, das führt wohl zu den deutlich auffälligeren schwarzen Strichspuren der störenden Hotpixel.


    Bei hellem Himmelshintergrund (oder bei Hotpixeln innerhalb heller Bildbereiche wie Gasnebel) führt die Hotpixelkorrektur oft zu unnatürlich dunklen Punkten, die durch Guiding dann zu Strichspuren als Folge der Korrekturbewegung des Bildfelds als Abbild der Missweisungskorrektur werden.
    Bei meinen Guidingkameras (PHD2) bevorzuge ich statt der Hotpixelkorrektur übrigens das Defect Pixel Mapping, wo ein Fehlpixel durch die mittlere Helligkeit der aktuellen Umgebungspixel ersetzt wird. Das verhindert diese dunklen Spuren.


    Gruss
    Günter




    Gruss
    Günter

  • Hallo,


    interne Rauschunterdrückung einer DSLR - ist das nicht bereits ein kamerainterner Dunkelbildabzug? Wenn man dann noch zusätzlich gemachte Darks abzieht ist das eine Überkorrektur, die zu Lochfraß bzw. solchen Spuren führen kann, denke ich.


    Grüße, Gerd

    Es schaute mich an - und ich schaute Es an.
    Und errötend wich Es zurück - das Universum.


    Bresser 102/460 | Tasco 76/1200 | Tasco 60/1200 | Tasco 60/900 | Tasco 60/700 | Tasco 50/600 | Minolta Bino 10x42 | Kasai s'Gucki 2.3x40

  • Hallo zusammen,


    ich hatte ja bereits geschrieben, dass das Auftreten scheinbar doch nicht an der verwendeten Optik, sondern wirklich nur an der Höhe der ISO (Ab ISO 3200 treten keine Hotpixel mehr auf) und der Qualität des Guidings liegt.


    Das mit der internen Rauschunterdrückung kann möglich sein, würd ich aber auch ausschließen. Auf den Rohbildern sind die Hotpixel deutlich erkennbar - nur die ISO und die Blz verändern diese - und eben auch ohne Dark-Abzug sieht man im Ergebnis dunkle Streifen.


    Anbei hängt jetzt nochmal das Bild von M13. Gleiche Belichtung (2min) bei ebenfalls ISO1600, gleiche Hotpixel wie schon beim Kometen sichtbar, nur das Guiding war viel genauer.
    Beim Kometen war der Verzug von anfangs- zu Endbild ca. 100px, Aufgeteilt auf 64 Aufnahmen. Bei vollem Zoom erkennt man sehr leicht verzogene Sterne, aber eben nur um 2-3 Pixel.


    Trotzdem, das Bild von M13 zeigt garkeine Dunklen Flecken, nichtmals punktuell. Der Komet schon. Es muss also wirklich was damit zu tun haben, wie DSS die Bilder verrechnet.
    Hab alle Methoden mal verglichen, also jeweils einmal Darks abgezogen und einmal nicht. Sobald das Guiding passt, verschwinden die schwarzen Flecken:



    https://up.picr.de/38709668kf.jpg


    Was mich viel mehr verdutzt: Normal ist der Prozess in DSS ja eigentlich folgender:


    - Light laden
    - Dark abziehen
    - Stacken


    Dabei dürfte es dann doch eigentlich völlig egal sein, ob das Guiding verzogen ist oder nicht. Das Ergebnis sollte eigentlich immer das gleiche bleiben. (Zumindest bei genau gleichen Kameraeinstellungen und Darks)
    Möglich wäre noch, dass DSS bei perfektem Guiding die späteren Hotpixel nach dem Stacking erkennt und nochmals rausrechnet, während dieser Prozess bei den Strichspuren fehlschlägt.


    Viele Grüße und ein schönes Wochenende
    Tobi

  • Hallo Tobi,


    der Unterschied zw. ISO 1600 und 3200 ist einfach nur eine 2-fache Verstärkung. Wenn dadurch die Hotpixel verschwinden, tut das die Kamera ganz gezielt - und das ist nicht wünschenswert.


    Wenn du sicher bist, dass die dunklen Streifen auch ohne Darks auftreten, müssten eigentlich tote Pixel dafür verantwortlich sein, was ungewöhnlich wäre. Oder sie stammen vom Master-Flat (falls du eines verwendest). DSS kann jedenfalls nicht die Ursache sein.


    Du könntest du mal ein Light, das zu dunklen Streifen führt, hochladen.

  • Hallo Tobi,
    Die Reihenfolge bei dss stimmt, denke ich. Durch das subtrahieren sollten die hotpixel verschwinden.
    Durch das nicht perfekte guiding wird, meiner Meinung nach , jedes Bild leicht versetzt übereinander gelegt. Eigentlich sitzt dann der dunkle fleck immer leicht versetzt woanders. Es ist ja fast ein unbeabsichtigtes dithern und da sollte sich das doch Mitteln?
    Viele Grüsse

  • Hallo Tobi,


    ich hatte das Problem auch im letzten Jahr bei einer Canon EOS700da.
    Nach dem Stacken in Sequator war mein Hexenkopfnebel über und über mit solchen Strichen.


    Hier habe ich für mich eine Erklärung gefunden:
    http://www.astrotreff.de/topic.asp?TOPIC_ID=252169
    http://www.astrotreff.de/topic…HIVE=true&TOPIC_ID=188755


    Habe mir meine Bilder dann alle genau angesehen und festgestellt, dass genau an den Stellen HotPixel waren, die dann durch das nicht ganz genaue Nachführen mit einer kleiner Skywatcher Star Adventurer durchs Bild gewandert sind.


    Habe die Bilder dann mal mit Darks in Sequator gestackt und die Striche waren weg (auch wenn es keine passenden Darks waren).
    Und auch in DSS waren die Striche weg.


    Außerdem habe ich mehrmals eine manuelle Sensorreinigung durchgeführt.
    Seitdem habe ich diese Striche nicht mehr gehabt (auch ohne Darks).


    Viele Grüße
    Sabine

    Meine Ausrüstung
    Montierung: ioptron CEM40, Skywatcher Star Adventurer Pro

    Kamera: Altair Hypercam 26C, Canon EOS700Da

    Teleskop: TS Photoline 80 mm f6 (380/480 mm)

    Objektive: Canon 200 mm, Samyang 135 mm, Sigma 18-35 mm, Canon 60 mm

    Guiding: MGEN3

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!