Statistik
Besucher jetzt online : 264
Benutzer registriert : 22074
Gesamtanzahl Postings : 1088408
Der Astronomie-Chat ... Live Diskutieren, Fragen stellen, Kontakte knüpfen ... Jederzeit mit anderen Sternfreunden in Echtzeit plaudern ...
Benutzername:
Passwort:
Passwort speichern
Passwort vergessen?

 Alle Foren
 Astronomie - die Technik (Datenverarbeitung)
 Technikforum Bildverarbeitung
 Hilfe! Darkframe-Abzug geht immer in die Hose!

Hinweis: Sie müssen sich registrieren, um eine Antwort schreiben zu können.
Um sich zu registrieren, klicken Sie hier. Die Registrierung ist kostenlos!

Auflösung:
Benutzer:
Passwort:
Funktion:
Format: FettKursivUnterstreichenDurchstreichen Links ausrichtenZentrierenRechts ausrichten Horizontale Line Hyperlink einfügenEmail einfügenBild einfügen Code einfügenZitat einfügenListe einfügen Spoiler einfügen
   
Nachricht:

* HTML ist AUS
* Forum Code ist AN
Smilies
Lächeln [:)] Lachen [:D] Cool [8D] Erröten [:I]
Lechzen [:P] Teufel [):] Winken [;)] Clown [:o)]
Blaues Auge [B)] Achter Kugel [8] Angst [:(] Schüchtern [8)]
Schockiert [:0] Verärgert [:(!] Erschöpft [xx(] Müde [|)]
Küsse [:X] Zustimmen [^] Mißbilligen [V] Frage [?]

  Signatur anhängen.
Dieses Thema abonnieren.
    

Ü B E R S I C H T    
Matein Erstellt am: 30.04.2019 : 17:36:24 Uhr
Moin,
ich bin inzwischen bereit, Darkframes zu machen und zu verarbeiten. Aber: das Summenbild in DSS wird dann nur noch so um die 900KB! klein und das Objekt ist nicht mehr zu sehen, nur noch ein paar Sterne auf krass schwarzem Hintergrund. Ausgangssituation: Jeweils 15x 360 Sekunden HA, OIII und SII von IC 1396. 15 Darks, gleicher Gainwert, gleiche Chiptemperatur, gleiche Belichtungsziet. Für jeden Filter 15 Flats mit Hilfe des APP-Tools dafür. Wenn ich Flats und Lights zusammen stacke, klappt alles. Größe: um die 70MB. Sobald die Darks hinzu kommen, ist das Bild für die Tonne. Woran könnte es liegen?
VG Martin
D I E    15   L E T Z T E N    A N T W O R T E N    (Neue zuerst)
ErwinL Erstellt am: 03.05.2019 : 16:06:16 Uhr
Hallo HB, danke, das ist, was mir entgangen war. Ich hatte angenommen, dass wie bei den DSLRs nicht hochskaliert würde.

(==>)Martin: Normalerweise braucht man die Faktoren nicht, weil man, wie Jörg und andere schon geschrieben haben, immer passende Darks aufnehmen sollte.
Nur wenn man's mal besonders eilig und keine exakt passenden Darks hat, kann man damit solche, die nicht zu weit weg liegen, umrechnen.
Bikeman Erstellt am: 02.05.2019 : 21:39:51 Uhr
Zitat:
Original erstellt von: ErwinL

Hallo Martin,

bei einem zweiten Blick auf deine FITS Dateien ist mir noch etwas Seltsames aufgefallen: Obwohl es 16-Bit Files sind und die Bilder bis 12 Bit nutzen, ist die Auflösung nur 8 Bit, weil nur Helligkeitswerte vorkommen, die Vielfache von 16 sind.



Also die Pixelwerte in den FITS frames gehen schon bis etwa 65k (2^16) (schau mal die ausgebrannten Sterne an).

Wenn diese Werte nur Vielfache von 16 sind (2^4) ergibt das gerade eine Auflösung von 16-4 = 12 bit, und nicht 8 bit, es ist also alles in Ordnung. Offenbar werden die Bilder schon von der Aufnahmesoftware von 12 bit auf 16 bit skaliert, indem die Roh-Werte mit 16 multipliziert werden. Bei SharpCap z.B. kann man das je nach Wunsch ein- und ausschalten.

CS
HB
Matein Erstellt am: 02.05.2019 : 19:53:59 Uhr
Hallo Erwin, davon verstehe ich leider nicht viel. Laut Beschreibung hat die 183 wohl 12 Bit. In den Aufnahmeeinstellungen kann man aber entweder nur 8 bit oder 16 bit auswählen.
Muss ich deine Erkenntnis über den Faktor irgendwie bei der Bildkalibrierung oder Bearbeitung berücksichtigen?
VG Martin
ErwinL Erstellt am: 02.05.2019 : 15:15:28 Uhr
Hallo Martin,

bei einem zweiten Blick auf deine FITS Dateien ist mir noch etwas Seltsames aufgefallen: Obwohl es 16-Bit Files sind und die Bilder bis 12 Bit nutzen, ist die Auflösung nur 8 Bit, weil nur Helligkeitswerte vorkommen, die Vielfache von 16 sind. Ich weiß nicht, ob man das irgenwie einstellen kann, oder ob ich vielleicht einen Fehler gemacht habe. Vielleicht kann da mal noch jemand draufschauen, der sich mit der Kamera auskennt.

Nebenbei hab ich noch gesehen, dass in den FITS nicht nur drinsteht, welches Gain du eingestellt hast, sondern auch, welche Verstärkung das bewirkt. Und das ergibt ungefähr den Faktor drei zwischen Light und Dark.
Lars73 Erstellt am: 01.05.2019 : 22:59:55 Uhr
PS:
Habe gerade ausprobiert:
Ein von DSS automatisch gespeichertes autosave.tif lässt sich in fitswork ganz leicht so anpassen,
daß es einem mit "Speichern unter" gespeicherten tif entspricht.
Man öffnet also in fitswork das autosave.tif und wählt im Histogramm-Menü "Auf 16 Bit skalieren (0->65535)".
Gruß Lars
Bikeman Erstellt am: 01.05.2019 : 22:45:28 Uhr
Na da hat sich die Mühe doch gelohnt, sehr schön!
CS
HBE
Matein Erstellt am: 01.05.2019 : 21:49:33 Uhr
Danke euch für die Hilfe, ich habe daraufhin ein drittes mal 10 Darks mit APT erstellt und nochmal penibel auf alles geachtet. Und siehe da - alles gut! Plötzlich klappts! Und somit ist auch endlich das Verstärkerglühen verschwunden, hätte ich nicht zu hoffen gewagt. Das fertige Bild findet ihr hier: https://www.astrobin.com/403445/B/?nc=user

VG Martin
ErwinL Erstellt am: 01.05.2019 : 21:26:24 Uhr
Hier ist das Light nach Abzug des Dark * 0.35 und mit dem Masterflat geebnet. Nur etwas aufgehellt, ohne weitere Nachbearbeitung.
optikus64 Erstellt am: 01.05.2019 : 21:04:26 Uhr
Hallo Martin,

ausgehend von den geposteten Bildern bin ich bei Erwin,

die Frames scheinen zu passen, es wird wie er sagt, die Skalierung sein. Man kann es nur so oft wie möglich betonen, die Kalibrieraufnahmen müssen exakt passend erstellt werden. Wenn alle (Lights, Darks, Bias, Flats) wirklich mit denselben Kameradaten erstellt wurden klappt die Verarbeitung sowohl bei DSS als auch PI wie an der Strippe gezogen zumindestens mit akzeptablen Ergebnis, den Rest macht dann das Feintuning. Die Thematik hier ist ein gutes Beispiel welche Probleme nicht passend erstelle Kalibrieraufnahmen verursachen. Für uns alle eine gute Erinnerung!

CS
Jörg
ErwinL Erstellt am: 01.05.2019 : 19:25:49 Uhr
Es ist kein Problem der Verarbeitung, Light und Dark passen nur nicht zusammen. Wenn man das korrigiert, ist das Ergebnis nicht schlecht. Ich lade es dir hier mal hoch, das dauert nur immer etwas.
Matein Erstellt am: 01.05.2019 : 19:16:27 Uhr
Ich habe versehentlich heute eine Darkserie mit Gain 200 gemacht, die Lights haben aber nur 139. Egal, auch die passende Darkserie mit der gleichen Gaineinstellung führt zum gleich schlechten Resultat. Aber: In Fitswork wird die Bittiefe des Masterdarks mit -32 angegeben, die einzelnen Darks und die Lights haben 16. Ist hier der Fehler?
Ich stelle euch hier nochmal das Masterdark als Fits ein:
https://www.dropbox.com/s/6e9xji8t12wl6w2/Masterdark.fit?dl=0
ErwinL Erstellt am: 01.05.2019 : 19:06:37 Uhr
Das Dark hat einen ca. 3-fach höheren Pegel als das Light. Wenn man es mit 0.35 skaliert passt es ganz gut, auch der Amp-Glow wird gut kompensiert. Das spricht dagegen, dass Fremdlicht drauf ist. Eher stimmt was mit der ISO-Einstellung nicht.
Matein Erstellt am: 01.05.2019 : 18:49:21 Uhr
OK, hier kommen die Links zu den Bildern. Ja,ich meinte natürlich APT.

MasterDark: https://www.dropbox.com/s/ohwt32dle8ysrgc/MasterDark_ISO0_360s.tif?dl=0
MasterFlat: https://www.dropbox.com/s/ll3ninuyt33ywq5/MasterFlat_ISO0.tif?dl=0
Einzelnes Dark: https://www.dropbox.com/s/83oinxgyj5b7daz/D_2019-05-01_07-35-39_Bin1x1_360s__-20C.fit?dl=0
Einzelnes Lightframe: https://www.dropbox.com/s/bvy56jkjxp5b95q/L_3_2019-04-29_22-55-48_Bin1x1_360s__-20C.fit?dl=0

Bin gespannt was ihr sagt. VG Martin
Lars73 Erstellt am: 01.05.2019 : 18:27:31 Uhr
Hallo Stefan, danke für den Tip.
Gruß Lars
Bikeman Erstellt am: 01.05.2019 : 17:40:37 Uhr
Ich denke am einfachsten wäre es wenn Du mal einen einzelnes Dark-Frame, Light Frame und dein Master-Flat als FITS file hier zur Verfügung stellen könntest, dann könnte man sofort feststellen ob es an dem "Rohmaterial" liegt oder an dem Stacking.

Wenn Du "APP-Tool" schreibst meinst Du eigentlich APT , oder?

Eine Besonderheit bei der ASI 183mm ist die relativ geringe Bit-Tiefe von "nur" 12 bit , d.h. die Pixelwerte sind im Bereich 0..4095 . Im Grunde genommen ist das kein Problem, nur haben bestimmte Tools die Option solche Daten auf 16 bit zu skalieren. Auch das ist problemlos, wenn es denn für alle Rohdaten konsistent gemacht wird. Wenn z.B. die Darkframes auf 16 bit hochgerechnet werden, die Light Framnes aber nicht, würde es genau zu dem oben beschriebenen Effekt kommen.

Anhand von Beispielframes kann man das ganz einfach kontrollieren, man schaut sich einfach die Maximalwerte der (unvermeidbaren) Hot-Pixel an. Die sollten bei Dark- und Light Frames gleich sein, also bei beiden entweder 4095 oder 65535, aber nicht beim einen so und beim anderen anders :-). Dein Master-Dark ist erstaunlich frei von Pixelfehlern...da scheint also schon eine gewisse Bearbeitung stattgefunden zu haben? Rohdaten wären besser für die Diagnose.

Bei den Dark Frames ist es nun auch wichtig dass sie bei annähernd der gleichen Temperatur aufgenommen werden wie die Light Frames, insbesondere natürlich bei ungekühlten Modellen. Die ASI 183 mm PRO ist gekühlt, und die Temperatur wird in den Dateiheader der Fits Dateien geschrieben, man kann also die Temperatur bei der Aufnahme nachträglich kontrollieren. Wenn etwas bei der Kühlung nicht geklappt hätte könnte man es also auch anhand des "Rohmaterials" sehen.

CS
HBE




Astrotreff - Astronomie Treffpunkt © Astrotreff 2001 - 2019 Zum Anfang der Seite
Diese Seite wurde in 0.28 sec erzeugt. Snitz Forums 2000

Der Astrotreff bedankt sich für die Unterstützung von:



?